Fixing the code highlighter for WordPress

Many of my posts have some sort of code, shell script, or other syntax highlighted portion. I've loved the code highligher plugin for wordpress. The version I've been using (1.8) doesn't seem to have had any updates for quite some time. The only reason that bothers me in the slightest is that there is a syntax highlighting bug in bash commenting. Since the highlighting for the plugin is done with Geshi, You can just download the latest Geshi and overwrite the plugin geshi folder.

  1.  
  2. > cd /your/wp/plugins/code-highligher
  3. > wget http://superb-west.dl.sourceforge.net/sourceforge/geshi/GeSHi-1.0.8.4.tar.gz
  4. > # untar geshi files to the current directory
  5. > # note that the archive file has a top level geshi directory that the plugin file doesn't have.
  6. > # now, if I did this right, my bash comments can contain 'strings' and reserved words df, ls, etc
  7.  
  1. No Comments



css.php