Upgrading Gentoo 2007.0 to 10.0

So I left all these servers running gentoo a couple years ago. Now, after all this time (and uptime!), I want to install something.

Error:

emerge -av portage

These are the packages that would be merged, in order:

Calculating dependencies |
!!! All ebuilds that could satisfy ">=dev-lang/python-2.5" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-lang/python-2.5.4-r3 (masked by: required EAPI -1, supported EAPI 0)
- dev-lang/python-2.6.2-r1 (masked by: required EAPI -2, supported EAPI 0)
- dev-lang/python-2.6.2-r2 (masked by: required EAPI -2, supported EAPI 0)
- dev-lang/python-2.6.4 (masked by: required EAPI -2, supported EAPI 0)
- dev-lang/python-3.1.1-r1 (masked by: required EAPI -2, supported EAPI 0)
- dev-lang/python-2.6.3 (masked by: required EAPI -2, supported EAPI 0)

For more information, see MASKED PACKAGES section in the emerge man page or 
refer to the Gentoo Handbook.
(dependency required by "sys-apps/portage-2.1.6.13" [ebuild])

Hm. Yeah, I’m way out of date.

Solution: I found other sites that talked about forcing a python/portage install but I that sounded a little harsh. Instead, I found a snapshot of portage-2008.0 and replaced my /usr/portage with the contents of that.

 cd /usr
 rm -rf portage # or mv portage xxx
 wget http://gentoo.mirrors.tds.net/gentoo/releases/snapshots/2008.0/portage-2008.0.tar.bz2
 tar -xjpf portage-2008.0.tar.bz2
 cd /etc/
 rm make.profile
 ln -s /usr/portage/profiles/default/linux/x86/2008.0 make.profile
 emerge -av portage

That took me to portage-2.1.4.4.

From there, I can now go back to current 10.0 portage and emerge -av portage to get up to the current portage state.

Yeah, I really didn’t want to do a re-install.

7 thoughts on “Upgrading Gentoo 2007.0 to 10.0”

  1. Had the same issue and this resolved it. I have a relatively ‘old’ version of Gentoo running (september 2007) and didn’t do any upgrade in the meanwhile and got this error.

    Thanks for the article.

  2. One slight problem. There’s a load of archectures out there with this problem and without 10.0 / 10.1 so for these users it’s going to be impossible to update in anyway shape or form, since with the latest available is 2008.

    In other words gentoo now only supports x86.

    This will be the point in time when gentoo and I part company.

  3. Another option is to take binary packages from newer systems, fetch all to the necessary system and then manually emerge each tbz2 file – bit of a pain. But, works fast and on multiple arch. HTH

Leave a Reply

Your email address will not be published. Required fields are marked *